Installiamo i Catalyst 8.12 in fedora 9 [AGGIORNATA! Dicembre]


Attenzione: questa guida è rivolta a chi non è propriamente alle prime armi con Linux… Se non sapete cosa state per fare, o non sapete come eventualmente riparare problemi, è meglio che attendete i driver pacchettizzati da LIVNA

Preparativi

Sarebbe una ottima idea rimuovere eventuali vecchi driver by Livna oppure installazioni di fglrx precedenti con installer..

Se avete installato da repository Livna:

su

yum remove kmod-fglrx livna-config-display

exit

Se avete installato i driver con installer ati:

cd /usr/share/ati

su

./fglrx-uninstall.sh

Per adesso non riavviate😉 Se proprio dovete, dovreste prima ripristinare xorg.conf con i driver opensource… ma cerchiamo di non fare errori🙂

Installiamo un pò di essenziali necessari

su

yum -y install kernel-devel kernel-headers make gcc gcc-c++ libstdc++ libgcc mesa-libGL mesa-libGL-devel fontconfig fontconfig-devel freetype freetype-devel zlib zlib-devel

Passiamo all’installazione dei nuovi FGLRX

wget https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-8-12-x86.x86_64.run

su

sh ati-driver-installer-8-12-x86.x86_64.run

Fate una installazione normale…cliccate sempre su continue… I agree…automatica🙂 senza generare pacchetti ne niente.. basta che cliccate sempre avanti…

Se tutto va bene e avete seguito alla perfezione questa guida, dovreste avere questo risultato:

okfglrx

A questo punto prima di riavviare e goderci i nuovi FGLRX, mettiamo a punto xorg.conf🙂

su

aticonfig --initial -f

Facciamo alcuni ritocchi a mano:

gedit /etc/X11/xorg.conf

Modifichiamo la sezione device in questo modo:

Section "Device"
Identifier  "aticonfig-Device[0]-0"
Driver      "fglrx"
BusID       "PCI:1:0:0"
Option "AccelMethod" "exa"
Option "XAANoOffscreenPixmaps" "true"
Option "TexturedVideo" "On"
Option "UseFastTLS" "1"
Option "Textured2D" "on"
Option "VideoOverlay" "Off"
Option "OpenGLOverlay" "Off"
EndSection

Aggiungiamo questo alla fine del file

Section "Extensions"
Option "Composite" "On"
Option "RENDER" "On"
Option "XVideo" "On"
EndSection

A questo punto, non vi rimane che riavviare e godervi i vostri driver freschi🙂

Teoricamente dovrebbe andare tutto liscio… in caso di emergenza, cancellate il file xorg.conf in modalità single user…come spiegato qui sotto.

IN CASO DI EMERGENZA

PER QUALSIASI PROBLEMA…. In caso che xorg si rifiuta di avviarsi o avete schermate nere… potete rimediare in un modo semplicissimo:

  1. All’avvio, interrompete il conto alla rovescia del bootloader (grub).. premendo una freccetta…
  2. Premete il tasto E della vostra tastiera, in modo da poter modificare i parametri di avvio
  3. Portatevi a questa riga: kernel /boot/vmlinuz-2.6.23.15-137.fc8 ro root=LABEL=/1 rhgb quiet
  4. Inserite dopo “ro” : single
  5. Dovrebbe apparire così: kernel /boot/vmlinuz-2.6.23.15-137.fc8 ro single root=LABEL=/1 rhgb quiet
  6. Date Invio, e premete B per fare partire il sistema con questi parametri modificati..
  7. Invece di avviarsi normalmente, partirà il modalità “single user”… Avrete la riga di comando sotto mano, con privilegi di superutente (Root)
  8. Date il comando: rm -rf /etc/X11/xorg.conf
  9. Riavviate il sistema: reboot
  10. Vi dovrebbe partire normalmente il sistema, con i driver vesa…

7 Risposte

  1. Grande, grazie … è vero funziona perfettamente finalmente funziona anche con la mia radeon x1300, non li avevo installati aspettando la nuova versione ma la tua guida mi a rinfrescato la memoria. bella guida chiara e completa . grazie

  2. […] se volete seguire l’esempio, potete seguire la mia vecchia guida (che aggiornerò) […]

  3. In Fedora 9 Preview 64 bit con ati 3850, fatto esattamente come dici, ottengo:
    dlopen:/usr/lib64/xorg/modules/drivers//fglrx_drv.so:
    undefined symbol: miZeroLineScreenIndex

    ciao

  4. strano, sono istruzioni banali e generiche..

    prova magari a chiedere sul forum di phoronix: http://www.phoronix.com/forums/forumdisplay.php?s=93381229388a8957baf1073d05c1a363&f=19

    magari hanno qualche dritta per la tua scheda..

    Anche se sinceramente, credo sia un cattivo supporto dei driver ati alla tua scheda… sono acerbi con schede e chip vecchi come il mio…figuriamoci per la tua che invece è nuova😀

  5. […] Al solito, aggiornata la guida per installarli su fedora […]

  6. niente da fare pero’ con il kernel ultimo…. sigh

  7. karl ho seguito tutto alla perfezzione… sistemato lo xorg… riavvio il sistema tenta di caricare X e mi da’ errore…. fa’ inserire la pass di root e rimpiazza lo xorg con uno di base….

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger cliccano Mi Piace per questo: