Aggiornare Firefox all’ultima versione su Ubuntu/Kubuntu


ATTENZIONE OGGI 23/10/2007 E’ USCITO L’AGGIORNAMENTO UFFICIALE UBUNTU/KUBUNTU PER FIREFOX! QUINDI AGGIORNATE ALLA 2.0.0.8 CON IL PACCHETTO UFFICIALE! Questa guida va usata SOLO quando non c’è il pacchetto ufficiale

Sarò spartano nelle mie soluzioni… ma cerco sempre la via più veloce ed intuitiva per scavalcare i problemi.

Ecco come ho semplicemente aggiornato alla 2.0.0.8 Firefox..dato che sulla mia Kubuntu 7.10 Gutsy Gibbon ero fermo alla 2.0.0.6

Intanto scarichiamo l’ultima versione dal sito di mozilla, aprite terminale e date:

wget http://ftp-mozilla.netscape.com/pub/mozilla.org/firefox/reases/2.0.0.8/linux-i686/it/firefox-2.0.0.8.tar.gz

Abbiamo cura di scompattarlo

tar -xvf firefox-2.0.0.8.tar.gz

CHIUDETE EVENTUALI FINESTRE APERTE DI FIREFOX

e diamo questo comando:

sudo cp -r ~/firefox/* /usr/lib/firefox/

Un pò spartano come metodo.. ma con questo comando copierà tutti i files e cartelle appena scompattati, nella cartella del programma Firefox… e di fatto aggiornerà all’ultima versione…

firefoxnew

Se qualcosa dovesse andare storto… basta rimuovere firefox e ripulire per bene con sudo aptitude purge firefox ed installarlo di nuovo con sudo aptitude install firefox ma non dovreste avere problemi… quindi ignorate questa parte, l’ho scritta solo per sicurezza.


5 Risposte

  1. “Se qualcosa dovesse andare storto… basta rimuovere firefox e ripulire per bene con sudo aptitude purge firefox”

    In verità non basta: bisogna anche reistallare il pacchetto libnspr4-0d
    perché con la tua installazione viene sovrascritta la libreria libplc4.so.0d.

  2. si vede che aptitude lo fa.. perchè ho provato a “sbagliare” con la procedura, e facendo un aptitude purge e un aptitude install mi ripristinava il firefox 2.0.0.6 perfettamente….

    in ogni caso è uscito il deb ufficiale, quindi questa guida è inutile allo stato attuale

  3. Interessante!
    Grazie e continua a postare i metodi pratici…a noi incapaci servono proprio questi!
    Thankyouthousand.

  4. ciao,
    ho provato ma mi da questi errori impossibile sovrascrivere la non-directory
    e non me lo aggiorna.. secondo voi come mai? Ho ubuntu 7.10 e volevo mettere firefox 2.0.0.11 invece di .6

  5. ma possibile che ancora non ci sono i pacchetti ufficiali? purtroppo non ho una ubuntu sotto mano, quindi non so dirti, mi spiace

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger cliccano Mi Piace per questo: